Page 2 of 2 First 12
Results 41 to 57 of 57

Thread: Mxsport issues

  1. #41

    Join Date
    Jan 2006
    Posts
    40
    Quote Originally Posted by rchalker View Post
    Welcome back Bill, I'm glad to hear you are getting a MX Sport. I know you will like it. It has some sweet reviews on how well it works. It doesn't get much easier than this machine.
    Thank You. I do miss my old MXT and hope the MX Sport is it’s lighter water proof son..Lol.

    I have read good reviews on the MX Sport. I always liked the build and quality of White’s detectors. I found my first gold coin with a White’s XLT years back. Also the M-6 is quite the detector in its own right.

    All The Best,
    Bill G
    Last edited by Bill G; 11-19-2018 at 04:10 PM.
    Every find is a good find!!!! some are just great!!!!<br />Whites XL Pro<br />Whites MXT

  2. #42

    Join Date
    Apr 2011
    Location
    Oklahoma
    Posts
    431
    Make sure that thew coil is not near the target when you push the pinpoint button.

  3. #43

    Join Date
    Jan 2006
    Posts
    40
    Quote Originally Posted by brreeder73505 View Post
    Make sure that thew coil is not near the target when you push the pinpoint button.

    Lol... Good old VCO pin point all metal got you.


    All The Best,
    Bill G
    Every find is a good find!!!! some are just great!!!!<br />Whites XL Pro<br />Whites MXT

  4. #44

    Join Date
    Oct 2016
    Location
    Franklin County, Missouri
    Posts
    42
    My Whites pinpointer drives my MXS crazy if it gets within 2 feet of the coil.

  5. #45
    rchalker's Avatar
    Join Date
    Dec 2010
    Location
    Youngstown, Ohio, USA
    Posts
    8,826
    Try offsetting the frequency. That will clear it up.
    AKA: Rodney _______ Detectors Used:
    ___________________White's Spectra V3i with DX-1
    ___________________White's TreasurePro
    ___________________Bounty Hunter Discovery 3300



  6. #46
    deolslyfox's Avatar
    Join Date
    Jul 2008
    Location
    Central Florida
    Posts
    49,427
    Freq Offset may work as Rod said. You can also point the coil away from the pinpointer, since the TRX field is strongest at the tip. Easiest is just to keep distance between 'em.
    If there's anything I hate worse than diggin' pulltabs, its missin' a gold ring.

  7. #47
    deolslyfox's Avatar
    Join Date
    Jul 2008
    Location
    Central Florida
    Posts
    49,427
    Oldremguy: Did you get the kinks worked out with the Sport ?? Hope its workin' OK for you now. If so, what was the "fix" ?? This is how we all learn. Thanks ....
    If there's anything I hate worse than diggin' pulltabs, its missin' a gold ring.

  8. #48
    THing4CSA's Avatar
    Join Date
    Feb 2009
    Location
    Wilmington, NC
    Posts
    3,884
    Hi My Fellow TH'ers
    Well, I tried all the suggestions that Whites Customer Service gave me and still not happy with how my MX-Sport was operating so it is on it's way back to Sweethome for a fix or replacement. It was working alright on dry sand but it was going nuts on wet sand or in the water. I tried both of my coils and both gave the same response. Steve at Whites customer service suggested to send it in for a warranty fix. I was having the issues of the icons jumping all over. I have no problems waiting on customer service to take care of my detector. ;-)

  9. #49
    rchalker's Avatar
    Join Date
    Dec 2010
    Location
    Youngstown, Ohio, USA
    Posts
    8,826
    I hope you get your Sport back soon CSA.
    AKA: Rodney _______ Detectors Used:
    ___________________White's Spectra V3i with DX-1
    ___________________White's TreasurePro
    ___________________Bounty Hunter Discovery 3300



  10. #50
    I thought my MX Sport was messed up till I found the audio I liked finally getting used to thresholds ets now I love my Sport

  11. #51
    Quote Originally Posted by deolslyfox View Post
    Oldremguy: Did you get the kinks worked out with the Sport ?? Hope its workin' OK for you now. If so, what was the "fix" ?? This is how we all learn. Thanks ....
    I haven’t made it back out since that 1-1/2 hour hunt. After the rain stopped in November it turned to snow in upstate New York. How we had 15 inches of snow dumped on us last weekend with -15 wind chill. It looks like I won’t make back out to test the MX Sport again until the end of March or April. We usually get about 120 inches of snow for the season. Will give you an update when the weather breaks. I seen last week on facebook that someone on the MX Sport site was having the same problem and was looking for help also.

  12. #52
    deolslyfox's Avatar
    Join Date
    Jul 2008
    Location
    Central Florida
    Posts
    49,427
    Good luck with your new Sport !!
    If there's anything I hate worse than diggin' pulltabs, its missin' a gold ring.

  13. #53
    THing4CSA's Avatar
    Join Date
    Feb 2009
    Location
    Wilmington, NC
    Posts
    3,884
    Hi My Fellow TH'ers
    Well I sent my MX-Sport back to Sweet Home for a check out and after a week of poking and prodding, Whites did what they do when a problem shows up, they sent me a replacement MX-Sport! You just can't get better service anywhere! I did manage to get out for a couple of hours yesterday (Sat 2/9/2019). I was invited to join my Dentist to search an area where damaged ships are repaired or scrapped. I found a lot of large iron as well as some brass and copper fittings, also the normal aluminum cans and bits of iron. Most of my finds went straight into my curbside recycle container but I did keep the copper and brass for my paid recycling. I plan to get out either Friday or Saturday but will stick to one of my sites that has given up a few coins over the past few years. I may suggest hitting the beach to see if the MX-Sport will work any better on the wet sand than the 1st one did. I am always hopeful that this one will not go bonkers on the wet sand as the original unit did. We shall see. More to follow. Thank you Whites for super service! ;-)

  14. #54
    rchalker's Avatar
    Join Date
    Dec 2010
    Location
    Youngstown, Ohio, USA
    Posts
    8,826
    Sorry to hear you had problems with your machine but I'm glad to hear you got your MX Sport replaced. Good luck with the new one. Happy hunting!!!
    AKA: Rodney _______ Detectors Used:
    ___________________White's Spectra V3i with DX-1
    ___________________White's TreasurePro
    ___________________Bounty Hunter Discovery 3300



  15. #55
    deolslyfox's Avatar
    Join Date
    Jul 2008
    Location
    Central Florida
    Posts
    49,427
    Thing4CSA:

    http://forums.whiteselectronics.com/showthread.php?75586-MX-Sport-Test-Results-Continuous-Update-4-23-16


    Check this .... Especially the part about working the beach ...

    Hope this is helpful.
    If there's anything I hate worse than diggin' pulltabs, its missin' a gold ring.

  16. #56
    THing4CSA's Avatar
    Join Date
    Feb 2009
    Location
    Wilmington, NC
    Posts
    3,884
    Hi My Fellow TH'ers
    I had major issues with my MX-Sport as it went bonkers on wet sand and in the water. The icons were jumping all other the place so sent it back to Whites. Whites replaced my MX-Sport with a new unit. I have only taken it out once so far and have yet to try the beach. It is more on land so am hoping that it will do better on the beach and wet sand. I will share an update as soon as I check things out on the beach.
    My younger brother had the same issue with his MX-Sport and sent it back to Whites. Whites replaced it with a new unit as well. I am thinking that there must be a software issue or maybe a problem with one of the boards. Doesn't matter as I am hoping that all is well with the new unit! ;-)

  17. #57
    AllenB's Avatar
    Join Date
    Oct 2006
    Location
    Columbus, Ohio
    Posts
    1,441
    Bud, I have the EXACT same problem. I've had the machine in for the upgrade, but it still performs like you've mentioned. Mine even gives off double signals/beeps. I've been around the hobby for over 13 years and I also use an MXT Pro...I just cannot get used to my MXS. it also swings MUCH more heavy than my MXT even though they are roughly the same weight. Right now the MXS collects dust
    Prizm IV - sold
    MXT - sold
    High end expensive "other brand" - big mistake...sold
    MXT Pro
    MXS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in