Results 1 to 3 of 3
  1. #1

    Problem with Pinpoint (Coinmaster)

    Hello everyone! I bought my Coinmaster in 2013 (SN:2191-0325-090-9376) and since then it have been working perfect until today. Now i have a problem (i searched for the forum and found out that a few people have got same problems too) with the Pinpoint which buzzing everytime i push its button. I've tried everything to solve this problem (change batteries, disconnect a coil, put it in an absolutely non-metal place(with or without coil), play with buttons) but unfortunately it gave nothing. May be someone gives me a piece of advice about this situation?

    Video proof:

  2. #2
    rchalker's Avatar
    Join Date
    Dec 2010
    Location
    Youngstown, Ohio, USA
    Posts
    5,592
    Welcome to the forum.
    Definitely sounds like a problem. I think you may need to sent it in for repair. Maybe someone else may have some ideas what causing this problem. Good luck.
    AKA: Rodney ________ Detectors Used:
    ___________________White's Spectra V3i with DX-1
    ___________________White's TreasurePro
    ___________________Bounty Hunter Discovery 3300


  3. #3
    deolslyfox's Avatar
    Join Date
    Jul 2008
    Location
    Central Florida
    Posts
    46,456
    Welcome !! I've seen posts of folks with the same issue. I'm with Rod - send 'er in. Whites will take care of you !!
    If there's anything I hate worse than diggin' pulltabs, its missin' a gold ring.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Log in

Log in